View Single Post
  #12  
Old 07-28-2009, 11:46 PM
argnob argnob is offline
Junior Member
 
Join Date: Jul 2009
Posts: 17
Default Template, paths, attempts to get something to run

Thanks for the clarification. This shows just how little I understand at the moment.

As freshly installed with no prefs.xml file present, I think I recall (though may be proven wrong) that PPL 2 (file released on 20/7/09) defaults to an Intel_Folder path of c:\ppl\pc\run\ .

Possibly I was supposed to check and adapt paths displayed when I ran the PPL IDE 2 for the first time - when it recognised that it was being run for the first time and presented some information about paths. In fact, I just assumed defaults would be sensible (based on the supposition that the setup file would know where it was putting the runtimes etc) and clicked past that screen.

Or maybe you're saying what's in the paths initially is irrelevant because the paths will get updated to appropriate paths when users create new projects based on the provided templates.

Just looking for something to run to verify that/or ascertain whether I had a working installation I picked the Desktop Form.prj template as something to try to run. I think I actually got that to execute and display a form once, I think twice, but now I get: cannot connect to server! My impression that finally I'd got something working was short-lived.

I've just had another go at running something. Starting a Console project, I couldn't find anything to double-click on which let me type in code, so I started a Code File project instead. Typed in ShowMessage('Hello world'); and ran it. It executed without error but no execution window was displayed. I wouldn't be surprised if the problem was lack of appropriate #INCLUDE headers (or equivalent - it's a long time since I've attempted anything with PPL whilst waiting for PPL 2 to come out) but then again, if #INCLUDEs were missing, surely the code wouldn't have run without compiler errors. It's also possible that an execution window came and went very quickly. Tried adding WaitForInput(1000000000000000000); but then I just got the familiar: Cannot connect to server!

I note that you have said there aren't example programs yet for PPL 2. Since me mentioning and you confirming that there are none, I've come across the Demos folder in the PPL 2 folder under My Documents but take it that these are all PPL 1.xx examples which have just been carried over. Perhaps you contemplate rewriting these, or some of them, for PPL 2 - or perhaps some are runnable as they are? A comment you made about PPL 2 running game and form based projects and PPL 1 projects made me suppose that some of these demos might be runnable in PPL 2 but I've had no success.

I think I'm going to give up for now and try out the updates you produce in due course in the hope that problems will have gone away - and wait for additional documentation. If the problems don't go away, I'll trouble you again but I can see that the more time you have to spend dealing with support requests the less time you have to spend on fixing the problems you already know about.
Reply With Quote