View Single Post
  #9  
Old 02-12-2010, 04:01 PM
veryalien veryalien is offline
Junior Member
 
Join Date: Feb 2010
Posts: 3
Default

Quote:
Originally Posted by CCJ View Post
Good news- I got Servulus to work by manually typing in the path you gave above. Also, I found I can at least get into the editor and vfb for 1.6.2 by selecting them from under the file menu at the splash screen. Double clicking on their respective icons under the tools tab at the splash screen is what brought on the aforementioned errors. Unfortunately, when I try to actually run some code [just ShowMessage("helloworld");] it comes back with-- PPL Runtime Error App: MAIN.PPL (WNDPROC) access violation at 0x3f700b8.


edit: scratch that, Servulus is not yet working for me- not only does it report the same odd runtime error with RUN(4,1) as before, but now it won't even let me tap the little house so I can check the options settings! Whenever I try it comes back with a different runtime error, this one claiming to have a problem with Proc: HANDLETOOLBAR(4,1) Opcode: NGPUSHVAR Char/Line/Offset: 0,0 0x004559e4 and an access violation at 0x119a18 by HANDLETOOLBAR(4,1).

Thanks for all the advice; I hope I can get this sorted out soon...
I have 1.6.2 installed and I also get 'random' access violations when running different PPL programs. I'm running PPL on a HTC Universal with a T-mobile WM5 ROM. I suspect something wrong with PPL memory management, but I'm a PPL newbie so I could be completely wrong.
But something is not happy with 1.6.2 on my pocket pc, can anyone else confirm/deny the (in)stability of PPL on WM5?

Edit: I just re-tried a few things and when I run the Servulus executable and use it to run PPL programs I don't get the same errors as when I use the normal 1.6.2 application. The demo programs run successfully without the access violations. The access violations don't seem to happen in the demo programs themselves, it seems to come from the 1.6.2 PPL application. It's a bit strange because I'm calling the same program as the Servulus PPL runtime! Something seems wrong in 1.6.2, but I don't really know how to report it as a bug. I will keep using Servulus because it removes the annoying errors I get when using 1.6.2 directly. Can anyone try to explain what is going on?

Last edited by veryalien; 02-12-2010 at 07:19 PM.
Reply With Quote